Firefox - Secure Connection Failed

1
Secure Connection Failed

An error occurred during a connection to catalog.neet.tv. SSL received a malformed Server Hello handshake message. Error code: SSL_ERROR_RX_MALFORMED_SERVER_HELLO

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

Wut, is the cyber police gonna catch me?
2
The root domain (neet.tv, without "catalog.") was using an expired SSL certificate. It's fixed now.

This normally didn't affect the catalog subdomain (catalog.neet.tv).
3
I still get this error. Do I have to clean something? Clearing cache doesn't help.
4
>Do I have to clean something?
History -> Show All History -> search for catalog.neet.tv -> right click on a page -> Forget About This Site.
This will clear all your filters and settings though.

But try in incognito or in another browser first, just in case.
5
It happens to me on several computers, doesn't seem to be some local data problem, but it only happens in Firefox.
I looked into Wireshark and compared the handshakes with catalog.neet.tv of Firefox and Chromium. I noticed that Firefox's handshake is listed as TLSv1.3 in the protocol column, while Chromium's is labeled as TLSv1.2. I disabled TLSv1.3 in Firefox by setting security.tls.version.max in about:config to 3. Now it works in Firefox.
So I guess there is a bug in the TLSv1.3 implementation of Firefox or neet.tv's server.
6
Confirm about FF
7
>>5
>security.tls.version.max
The default is 4 in the latest Firefox.
You must have some kind of very outdated version.
8
>>7
I think you misunderstood. I set it from the default (which is indeed 4) to 3. If it's set to 4 TLSv1.3 is enabled, if it's set to 3 it's disabled and the catalog is working.
9
OP here,I changed the security.tls.version.fallback-limit to 3 and then back to 4 and it works. Also there was a firefox update when I restarted ff.

Reply

Preview?
Draw